Back to Posts

ubuntu16에 pyldap 설치하기

Posted in ubuntu, tips, ldap

Problem

pyldap라이브러리를 이용해 AD Proxy/LDAP서버에 연결하기 위해서는 단순히 pip로만 설치하는 것 외에 사전으로 설치해야 하는 항목이 있다.

만약 설치가 되어있지 않으면 아래와 같이 에러가 난다.

In file included from Modules/LDAPObject.c:8:0:
Modules/errors.h:7:18: fatal error: lber.h: No such file or directory
compilation terminated.
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

Solution

sudo apt install python3-dev # python3
sudo apt install python3-pip # python3 pip3
sudo apt install build-essential # for c/cpp build
sudo apt install libsasl2-dev
sudo apt install libldap2-dev
sudo apt install libssl-dev

apt로 위 라이브러리 설치 후 아래와 같이 pip3으로 pyldap을 설치하면 된다.

pip3 install pyldap

넥슨코리아 인텔리전스랩스 어뷰징탐지팀에서 파이썬으로 개발을 하고 있습니다.
파이썬 + 웹 + 데이터 + ... 여러 분야에 관심이 많습니다.
글에 대한 문의등 연락은 아래 메일로 연락주세요.

Read Next

django에 MSSQL 연결하기